Core & Brand Connect - Downloads not completing
Incident Report for Webdam
Resolved
This incident has been resolved.
Posted Sep 10, 2021 - 12:30 PDT
Update
The download issue has been resolved, users may need to reinitiate downloads.
Posted Sep 10, 2021 - 12:05 PDT
Investigating
We are currently investigating the root causes of downloads not completing for some users.
Posted Sep 10, 2021 - 11:19 PDT
This incident affected: Core, Brand Connect, and Download.