Latency when navigating folders or uploading new images

Incident Report for Webdam

Resolved

This issue has been resolved.
Posted Mar 07, 2023 - 16:25 PST

Investigating

We have received reports of slowness with the platform and we are currently investigating the issue further.
Posted Mar 07, 2023 - 15:43 PST
This incident affected: Infrastructure, API, Core, Brand Connect, Workstream, Search, Uploads, and Download.