Latency issues in Core & Brand Portal

Incident Report for Webdam

Resolved

The platform is operational and is now resolved.
Posted Mar 14, 2024 - 11:02 PDT

Update

The platform is operational and is now resolved.
Posted Mar 14, 2024 - 11:02 PDT

Investigating

We are currently investigating this issue.
Posted Mar 14, 2024 - 10:10 PDT
This incident affected: Core and Brand Connect.