Degraded performance with downloads

Incident Report for Webdam

Resolved

This incident has been resolved.
Posted Jan 16, 2026 - 16:12 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 16, 2026 - 15:50 PST

Investigating

We are currently experiencing issues with downloads. We are working hard on the solution of this problem and will keep you updated on the progress.
Posted Jan 16, 2026 - 15:07 PST
This incident affected: Download.