DAM Experiencing Latency

Incident Report for Webdam

Resolved

This incident has been resolved.
Posted May 03, 2023 - 17:19 PDT

Monitoring

We are currently monitoring for any further issues, at this time Webdam is operational.
Posted May 03, 2023 - 15:31 PDT

Identified

The issue has been identified and we have deployed a fix.
Posted May 03, 2023 - 14:52 PDT

Investigating

We have received reports that this issue is still present. We are investigating these reports and will update here.
Posted May 03, 2023 - 11:17 PDT
This incident affected: Infrastructure, API, Core, Brand Connect, Workstream, Search, Uploads, and Download.