Degraded performance with uploads and downloads

Incident Report for Webdam

Monitoring

The issue surrounding delays for uploading and downloading assets has been resolved. We will continue to monitor this situation.

There are still ongoing issues related to displaying of thumbnails for certain customers due to the ongoing AWS incident. Our team is still looking into this with AWS at this time.
Posted Oct 20, 2025 - 17:32 PDT

Investigating

There are ongoing issues related to uploads and downloads due to the ongoing AWS incident.
Assets may get stuck in processing when uploading and asset downloads may fail. We are working hard on the solution of this problem and will keep you updated on the progress.
Posted Oct 20, 2025 - 14:33 PDT
This incident affects: Core, Brand Connect, Uploads, and Download.