DAM Experiencing Latency
Incident Report for Webdam
Resolved
This incident has been resolved.
Posted 27 days ago. Sep 17, 2019 - 14:58 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 27 days ago. Sep 17, 2019 - 14:28 PDT
Investigating
We are currently investigating.
Posted 27 days ago. Sep 17, 2019 - 12:39 PDT
This incident affected: Core, Brand Connect, and Workstream.