Webdam is currently unable to load
Incident Report for Webdam
Resolved
The incident has been resolved.
Posted Jul 29, 2024 - 11:48 PDT
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted Jul 29, 2024 - 07:30 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 29, 2024 - 07:15 PDT
Identified
The issue has been identified, and a fix has been implemented.
Posted Jul 29, 2024 - 07:08 PDT
Investigating
We are currently investigating reports that Webdam is not loading.
Posted Jul 29, 2024 - 07:02 PDT
This incident affected: Core and Brand Connect.